Help

Hibernate Search 4.5.0.Final is available now.

This minor release could be promoted quickly as we didn't include any new feature compared to the 4.4 series, other than to focus on compatibility with Hibernate ORM 4.3 and WildFly 8 (JPA 2.1 and JavaEE 7 respectively).

WildFly 8 Integration

The WildFly application server will include this Hibernate Search version, making it even simpler to get started. Our documentation explains how to activate the module, but this will be outdated soon!

Essentially you need to either

  • Add a line to the MANIFEST of your deployment

or

  • Declare the dependency in a jboss-deployment-structure.xml file included in your deployment

The documentation still instructs to download the necessary modules, as that's required with WildFly 8.0.0.CR1, but this step should not be necessary in the final version of WildFly 8!

Of course, we'll still provide the same modules in future so that you won't be limited to use the version included in WildFly exclusively, but will always have the option to choose a different version.

OpenShift users

Since Hibernate Search is being included in WildFly 8, we're looking forward to it being available to all OpenShift users via the WildFly cartridge.

Why should you upgrade?

To remind on all the good reasons to update, these are the most notable improvements of the 4.5 branch:

JPA 2.1 compatibility

This Hibernate Search version is meant to work with Hibernate ORM 4.3.x series: our implementation for the JPA 2.1 standard, now included in WildFly 8.

Improved performance

Both Hibernate ORM and Hibernate Search are getting leaner at each release, allowing you to make better usage of your memory.

Simplified MassIndexer

The MassIndexer is now simpler to tune, and some problems related to lazy initialization exceptions where resolved.

<dependency>
 <groupId>org.hibernate</groupId>
 <artifactId>hibernate-search-orm</artifactId>
 <version>4.5.0.Final</version>
</dependency>

Next steps

We expect to start rolling out preview tags of Hibernate Search 5 very soon: this is going to be based on the highly requested Apache Lucene 4.

Consequentially the 4.5 branch is from now on in maintenance mode, and will receive only critical fixes or as contributed by goodwilling users.

See our Roadmap for an overview of the plan, and don't hesitate to send suggestions our way!

1 comment:
 
05. Feb 2014, 13:12 CET | Link

I noticed that Hibernate ORM depends on jboss-transaction-api1.2 and Hibernate Search through infinispan 6 on jboss-transaction-api1.1. Is that something to exclude?